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A Introduction; requirements

ChemFormula is a macro that works in Microsoft Word, under Windows. 
ChemFormula allows you to type chemical formula expressions without worrying 
about formatting; ChemFormula will add formatting features, such as subscripts, 
superscripts, and raised dots.

ChemFormula will work in all versions of Microsoft Word, under Windows, from 
version 6 onwards. It was originally written for Word version 6, version 7 (also 
called Word for Windows 95 or Word 95), Word 97 (sometimes called version 8), 
and Word 2000 (version 9). It also works in more recent versions, including Word 
2003, 2007 and 2010, though we have limited experience with some of these. Any 
version of Microsoft Windows that supports your version of Word is acceptable. 

(Word and Windows are trademarks of Microsoft Corp.)

A Dutch language version of ChemFormula for Word versions 97 and newer is 
also available; it can be downloaded from the web site or obtained from the 
authors; see Sect P. Except for that, ChemFormula has been tested only with 
English language versions of Word.

 

B Distribution

ChemFormula includes five files:

1. MACRO6.DOC. For use with Word 6 or Word 7 (95). This contains the actual 
text of the ChemFormula macro. You can install it following the instructions in 
Sect D.

2. MACRO97.DOC. For use with Word 97 and more recent versions such as 
Word 2000 to Word 2010. This contains the actual text of the ChemFormula 
macro. You can install it following the instructions in Sect D.

3. CHEMFORM.PDF or CHEMFORM.DOC. This manual.

4. TESTFILE.DOC. A “test file” that will let you see many examples of how 
ChemFormula works. It is a Word 6 DOC file, which can also be read with later 
versions. See Sect I for more information about the test file.

5. README.TXT. A brief text file, with an obvious name, to assist users in getting 
started. 

ChemFormula is distributed as a ZIP file, CHEMFORM.ZIP, containing those five 
files.

A Dutch language version of ChemFormula for Word versions 97 
and newer is also available, as a separate file. Users of this version 
may also want to obtain the regular ChemFormula package, 
described above, to get the manual and testfile, which are available 
only in English.
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ChemFormula is “freeware”. You may distribute it to others, but may not charge for 
it.

Any distribution should include all five files, as described in this section.

Current versions of ChemFormula, including the Dutch language version, are 
available at the web site, or from the authors; see Sect P.

ChemFormula is supplied “as is”. The authors have made all 
reasonable effort to ensure that ChemFormula performs as 
described. However, the authors disclaim all warranties, expressed 
or implied, including, without limitation, the warranties of 
merchantability and of fitness for any purpose. The authors assume 
no liability for damages, direct or consequential, which may result 
from the use of ChemFormula.

The authors of ChemFormula realize that viruses contained in 
macros for Word are becoming increasingly common. ChemFormula 
is distributed as macro code in text format (rather than in binary), so 
users are encouraged to check the macro code to be assured that it 
does not contain viruses.

 

C Getting started

For basic installation procedures, see Sect D.

For the basics of how to use ChemFormula, see Sections E and F. 

Word often has many ways to carry out a task. To help those who may be 
unfamiliar with a particular operation, one way to do the task may be described in 
more detail, in this smaller type.

 

D Installation

Specific instructions for installation in various versions of Word follow.

The version of Word is shown on the Title screen that appears briefly each time 
you open Word. If you are already in Word, choose the Help menu, then choose 
About Microsoft Word.
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D.1 Installation of ChemFormula in Word 6 or Word 7 (95)

1. Choose the Tools Menu

2. Choose Macro

3. In the box under Macro Name, type the name: ChemFormula

4. Choose the Create button, at the right. Word will now switch from the 
document window to a macro editing window. 

5. Some text may be shown. Remove all text, so that the macro editing window is 
empty.

To remove all text: Choose the Edit menu, choose Select All, choose the Edit 
menu again, choose Clear.

6. Open the file MACRO6.DOC, which contains the text of ChemFormula for 
Word versions 6 and 7 (95). 

Choose the File menu, choose Open. 

Where the files are depends on how you obtained ChemFormula. In any case, all 
the files should be in the same disk directory. 

How you find the file depends on whether you use Word 6 or Word 7 (95).

Word 6. Check that the box under “File Name:” says “*.doc”. If not, click on the 
down arrow by “List Files of Type:” and choose “Word documents (*.doc)”. 
Check that the box under “Drives:” refers to the drive where the ChemFormula 
files are located. If not, click on the down arrow by “Drives:” and choose the 
correct drive. Then choose the directory where the ChemFormula files are 
located.

Word 7 (95). Check that the box entitled “Files of type:” says “Word Documents 

(*.doc)”. If not, click on the down arrow ( ) and choose “Word documents 
(*.doc)”. Check that the “Look in:” box refers to the drive where the 

ChemFormula files are located. If not, click on the down arrow ( ) and 
choose the correct drive. Then choose the directory where the ChemFormula 
files are located.

7. Select the entire MACRO6.DOC file, “copy” it, and then paste it into the macro 
editing window.

Choose the Edit menu, choose Select All, choose the Edit menu again, and 
choose Copy. Switch to the macro editing window: choose the Windows 
menu, and choose “Global: ChemFormula”. Then choose the Edit menu, and 
choose Paste.

8. Close the macro window: Choose the File menu, and choose Close. When 
Word asks if you want to save the macro, answer ‘Yes’.

9. Exit Word. If Word asks if you want to save changes to NORMAL.DOT, answer 
‘Yes’.
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D.2 Installation of ChemFormula in Word 97, Word 2000, or Word 2003

1. Choose the Tools Menu

In Word 2000 or Word 2003: If the menu option “Macro” does not appear, double-click the 
word “Tools” on the menu bar.

2. Choose Macro, then choose Macros in the pull-out menu

3. In the box under Macro name, type the name: ChemFormula

4. Choose the Create button, at the right. Word will now switch from the 
document window to a macro editing window. 

5. Some text may be shown. Remove all text, so that the macro editing window is 
empty.

6. Return to Word, by clicking on the taskbar item that includes “Microsoft Word”. 

For example, the taskbar item will say

“Microsoft Word” (Word 97)

OR

“ * - Microsoft Word” (Word 2000 or Word 2003, where the * is the name of an 
open document)

7. Open the file MACRO97.DOC, which contains the text of ChemFormula for 
Word 97 and more recent versions of Word. 

Choose the File menu, Choose Open. (In Word 2000 or Word 2003: If not visible, 
double-click “File” on the menu bar.) Check that the box entitled “Files of type:” 
says “Word Documents” (Word 97) or “All Word Documents”. (Word 2000 or Word 

2003). If not, click on the down arrow ( ) and choose “Word Documents” (Word 
97) or “All Word Documents”. (Word 2000 or Word 2003). Check that the “Look 
in:” box refers to the drive where the ChemFormula files are located. If not, click 

on the down arrow ( ) and choose the correct drive. Then choose the directory 
where the ChemFormula files are located.

Where the files are depends on how you obtained ChemFormula. In any case, all 
the files should be in the same disk directory. 

8. Select the entire MACRO97.DOC file, “copy” it, and then paste it into the 
macro editing window.

Choose the Edit menu, choose Select All, choose the Edit menu again, and 
choose Copy. Switch to the macro editing window: click on “Microsoft Visual Basic 
- Normal” on the taskbar. Then choose the Edit menu, and choose Paste.

9. Close the macro window: Choose the File menu, and choose “Close and 
return to Microsoft Word”. 

10.Exit Word. If Word asks if you want to save changes to NORMAL, answer 
‘Yes’.
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D.3 Installation of ChemFormula in Word 2007 (by Borislav Dopudja)

1. Open Word Options and enable Developer Toolbar. To do this, click on the 
Office Button (top left), select Word Options, and under Popular check the 
Show Developer Tab on the Ribbon checkbox.

2. Select Developer tab.

3. Select Macros. The Macros window opens.

4. Create a new macro by writing ChemFormula under Macro name and by 
clicking Create button. Microsoft Visual Basic window opens.

5. Open MACRO97.DOC document, select entire document (Home �  Select �  
Select All or Ctrl+A), and paste the copied content into the Visual Basic 
window (Ctrl+P).

6. Select: File �  Close to return to Microsoft Word.
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D.4 Installation of ChemFormula in Word 2010 (by Borislav Dopudja)

1. Open Word Options and enable Developer Toolbar. To do this, open Word 
Options: click File and select Options. Than select "Customize Ribbon," and on 
the right side make sure that “Developer” checkbox is checked. Click OK.

2. Select Developer tab.

3. Select Macros. The Macros window opens.

4. Create a new macro by writing ChemFormula under “Macro name” and by 
clicking Create button. Microsoft Visual Basic for Applications window opens.

5. Open MACRO97.DOC document, select entire document (Home → Select → 
Select All or Ctrl+A), and paste the copied content into the Visual Basic 
window (Ctrl+P).

6. Select: File → Close to return to Microsoft Word
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E How to run ChemFormula

There are various ways to run ChemFormula, depending on exactly how you 
installed it.

The procedures are the same for all versions of Word, except as noted.

In all cases, you first “select” some text you want formatted, as discussed in Sect 
F, then run ChemFormula.

 
1. If you have simply installed ChemFormula according to the instructions in Sect 

D:

• Select the text you want to format. See Sect F for more information.

• Word 6 or 7  : Choose the Tools Menu
Choose Macro
Find ChemFormula in the list of macros; double 

click on the name.

Word 97 or 2000: Choose the Tools Menu
Choose Macro
Choose Macros in the pull-out menu
Find ChemFormula in the list of macros; double 

click on the name.

Word 2007 or 2010: Choose the Developer tab
Choose Macros
Choose ChemFormula
Click Run

2. For greater convenience, you can add ChemFormula directly to a menu, as 
explained in Sect K and L. 

a. If you have ChemFormula on the Tools menu (Sect K), then to run it:

• Select the text you want to format. See Sect F for more information.

• Choose the Tools Menu

• Choose ChemFormula

b. If you have ChemFormula on the Shortcut (right-click) menu (Sect L), then to 
run it:

• Select the text you want to format. See Sect F for more information.

• Right-click

• Choose ChemFormula
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3. If you added ChemFormula to the Tools Menu and specified its name as 
Chem&Formula (Sect K), then you can run it by typing ALT T F (hold the ALT 
key down and type T, then F).

 
The ChemFormula macro, like any Word command, can be 
assigned to a keystroke or tool button, as well as to a menu. The 
information provided here just gives examples of how you might 
install ChemFormula.
 

F Using ChemFormula

Type text containing chemical expressions using the characters you want in the 
expression, but do not worry about superscripts, subscripts, and raised dots (as in 
hydrate complexes).

You must type the correct capitalization, parentheses or brackets, and spaces. 
ChemFormula does not adjust these.

ChemFormula does not correct errors. The purpose of 
ChemFormula is to minimize the need to manually format chemical 
expressions.

Select (“light up”) a portion of text containing a chemical expression -- a single 
formula or an entire equation. Run ChemFormula; see Sect E. 

 
ChemFormula will format the following parts of the chemical expression:

 
• It will subscript numbers that show how many of an atom or group are present.

Examples: H2O will be formatted as H2O.
Ca(NO3)2 will be formatted as Ca(NO3)2.

 
• It will superscript charges, both the sign and magnitude (if given). 

In some cases, ChemFormula will pause and ask whether a particular sign or 
number is part of the charge. 

Answer each such question by clicking on the Yes or No button just 
under the question, or by typing the Y or N key. The default is always 
‘Yes’; pressing the “Enter” key means ‘Yes’.

Example: Mg2+ will be formatted as Mg2+.

Not all chemical expressions can be formatted unambiguously, 
without further input. For example, O2- might reasonably mean 
either the oxide ion, O2-, or the superoxide ion, O2

-. Similarly, 
ChemFormula cannot tell whether NO3- means NO3

- or NO3-, even 
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though the latter is not a normal chemical species. Therefore, in 
such cases, ChemFormula will pause and ask a question.

 
• It will raise a “dot” (period; full stop) to mid-line, to indicate a complex such as 

a hydrate. ChemFormula will pause and ask whether a particular dot should be 
raised. 

Example: CuSO4.5H2O will be formatted as CuSO4·5H2O.

Changes to dots are not shown immediately on the screen. These 
changes will be made just before ChemFormula is done.

It may be convenient to select an entire line, or even an entire paragraph, that 
contains some chemical expressions. This is beyond the intended scope of 
ChemFormula, but will usually work. ChemFormula will format the chemical 
expressions and ignore text that does not look like chemical formula. However, 
you should check that text material was not altered; see Sect G.

 

G Notes and Limitations

ChemFormula is designed to distinguish chemical expressions from other text. 
This allows you the convenience of selecting a line, or small region, of text, rather 
than just the precise expression you want formatted. ChemFormula then formats 
the chemical expressions according to common conventions, and allowing for 
some variation in personal style. However, there are some limitations to its ability 
to make this distinction. This section discusses examples of limitations of 
ChemFormula; most of these are illustrated in the test file, Sect I.

ChemFormula may not always distinguish chemical expressions from non-
chemical expressions. It is most likely to err by trying to format mathematical 
expressions, or other letter and number combinations. Remember that 
ChemFormula is intended to be run with chemical expressions. If you use it on 
other expressions, especially with mixed letters and numbers, check that 
ChemFormula has not accidentally formatted the non-chemical text.

ChemFormula will treat a word that begins with a capital letter as if it were a 
chemical formula. If such a capitalized word contains numbers or hyphens or + or 
- signs, ChemFormula may attempt to format them. For example, ChemFormula 
will attempt to format Pre-owned or Talk2Me.

The use of chemical abbreviations other than element symbols may not be 
recognized by ChemFormula. In general, if the abbreviation “looks like” a chemical 
symbol, formatting will be ok. For example, it will accept Ph as an abbreviation for 
a phenyl group, and will format Ph3CH (triphenylmethane) properly as Ph3CH. 
However, if you use �  for phenyl, ChemFormula will not recognize it and will not 
format � 3CH.

 
ChemFormula will not work with decimal points in subscripts. It will not properly 
format Ca0.8Cu0.2O, intended to be Ca0.8Cu0.2O.
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ChemFormula will superscript charges, whether they are written with the charge 
sign before or after the number (e.g., Mg+2 or Mg2+). Negative charges can be 
written with either a hyphen or a “non-breaking hyphen”; ChemFormula will 
recognize them as equivalent. The following notes apply to charges:

1. If the charge is written in standard format, with the number first (e.g., Mg2+), 
ChemFormula will only recognize charges with one digit. 

2. Charges that are part of the formula of a compound can sometimes cause a 
problem. If an ion, with its charge, is in parentheses, it will always format correctly. 
If an ion, with its charge, is not in parentheses, ChemFormula may not properly 
distinguish the charge from the following subscript. For example, (Na+)2SO42- 
and Ca(Cl-)2 will format correctly [as (Na+)2SO4

2- and Ca(Cl-)2], but Na+2SO42- 
and CaCl-2 will not.

(Eliminating these limitations would lead to ChemFormula asking more questions 
during its operation. Since these situations are quite uncommon, we chose not to 
address them.)

 
Occasionally, ChemFormula will pause and ask a question -- and will position the 
message box directly over the text it is asking about. If this happens, drag the 
message box away from the text.

 
You should not switch to another window (either within Word or in another 
program) while ChemFormula is running. If you do, it will no longer be able to 
show the characters that are being questioned.

 
If ChemFormula ever fails to format a proper chemical expression, please advise 
the authors; see Sect P.

 

H Using ChemFormula with advanced features of Word

This section discusses how ChemFormula interacts with certain more advanced 
features of Word. There is no reason to read this section unless you use these 
features of Word. All of these are illustrated in the test file; see Sect I. 

 
Hidden text. ChemFormula is not affected by “hidden text”. If hidden text is 
displayed, then it will be formatted. If hidden text is not displayed, then it will not 
be formatted.

 
Text Boxes and Frames. ChemFormula will format text that has been set off in 
these boxes.
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Fields and bookmarks. ChemFormula will not format the result of a Word Field, 
including a Bookmark. If selected text includes a field result, ChemFormula 
ignores that part of the selection, but formats the rest of the selection properly.

(ChemFormula will properly format text that is marked as the 
definition of a Bookmark.)

 
Tables. Examples of the use of ChemFormula on different types of tables and 
table selections are given in the test file.

ChemFormula will properly format tables that are organized with spaces or tabs.

ChemFormula will format Word tables that are made with the Insert Table 
command. However, there are some restrictions (beyond the other limitations 
discussed).

Word 6/7/95. ChemFormula will format an entire Table, or any portion of the Table 
that you can select. That is, ChemFormula will format single cells, rows, columns, 
or any rectangular subset of the Table. ChemFormula will format a selection that 
includes non-Table text preceding the Table. It will not format non-table text 
following a table, in the same selection; if you make such a selection, 
ChemFormula will format any text prior to the Table and the Table, and will then 
display a message indicating that you should select the text following the Table 
separately.

Word 97/2000. For regularly shaped tables, ChemFormula will properly format 
most selections that include any combination of Table and non-Table text. The 
only exception is that it will not work if the selection is one or more columns 
(although an entire table can be formatted). For tables with irregular shapes, 
ChemFormula will not format across a merged row in certain situations. If 
ChemFormula ever cannot format a selection, it will stop and indicate this to the 
user.

I The Test File

The “test file”, TESTFILE.DOC, contains many examples of chemical expressions 
that ChemFormula will format. These are examples that we used in testing 
ChemFormula. We encourage you to experiment with this file to see how 
ChemFormula works.

The test file also contains examples to illustrate the limitations of ChemFormula, 
as discussed in Sect G, and the interaction of ChemFormula with various 
advanced features of Word, as discussed in Sect H.

 

J Correcting mistakes

If you make a mistake answering a question from ChemFormula, you can correct 
it by running ChemFormula again on the same text.
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If ChemFormula makes a formatting error without asking you a question:

• If it is in a valid chemical expression, please advise the authors of the situation 
that produced the error; see Sect P.

• If the error is in “ordinary text”, not a chemical expression, please note that 
ChemFormula cannot always distinguish text from chemical expression, if the 
text has features that make it look like a chemical expression. Most such errors 
will be due to abbreviations or mathematical expressions in the text, as 
discussed in Sect G. In general, you will need to avoid running ChemFormula 
on such text. If you feel that ChemFormula is not making a proper distinction 
between chemical and non-chemical text, please contact the authors; see Sect 
P.

 

K Optional: Adding ChemFormula to the Tools menu

Adding ChemFormula to the Tools menu is one way to make it easier to access; 
see Sect E.

Specific instructions for adding ChemFormula to the Tools menu in some versions 
of Word follow.  For versions of Word that are not listed, please consult the Help 
system in Word for further guidance.

(This section assumes that you have already installed the 
ChemFormula macro into Word; Sect D.)

 
Adding ChemFormula to the Tools menu; Word 6 or Word 7 (95)

1. Choose the Tools menu

2. Choose Customize

3. Choose the Menus tab

4. In the Categories box, on the left, find and choose Macro

5. Find the ChemFormula macro in the list of macros; choose the name.

6. Check the three settings at the bottom.

• “Change which menu”: Choose Tools.

• “Position on menu”: Auto is ok, but you might choose “At top”, so that 
ChemFormula is listed first.

• “Name on menu”: It will show as &ChemFormula. The letter following the & 
can be used as part of a keyboard shortcut. Using the C will conflict with 
the Customize command on this menu. To avoid this conflict, you might use 
Chem&Formula. If you do this, you can run ChemFormula with the key 
sequence ALT T F.
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7. Choose Add

8. Choose Close

9. Exit Word. If Word asks if you want to save changes to NORMAL.DOT, answer 
‘Yes’.

 
Adding ChemFormula to the Tools menu; Word 97 or Word 2000

1. Choose the Tools menu

In Word 2000: If the menu option “Customize” does not appear, double-click the word “Tools” 
on the menu bar.

2. Choose Customize

3. Choose the Commands tab

4. Choose “Macros” in the Categories window

5. Find “Normal.NewMacros.ChemFormula”. Choose this, and drag it to “Tools” 
on the menu bar. Then move it to an appropriate position within the menu.

6. Right-click the new menu item, and change the name (in the name box) to 
Chem&Formula. Press Enter.

7. Close the Customize dialog box.

8. Exit Word. If Word asks if you want to save changes to NORMAL, answer 
‘Yes’.

 

L Optional: Adding ChemFormula to a Shortcut (right-
click) menu

Adding ChemFormula to a Shortcut (right-click) menu is one way to make it easier 
to access; see Sect E. Shortcut menus are activated by clicking the right-hand 
mouse button.

Shortcut menus are “context-sensitive”. That is, there are several shortcut menus; 
which one appears depends on the type of selection. Most useful is the “Text” 
menu; this menu is the one that appears when you right-click on a selection of 
ordinary text. Those who use fields or tables may also want to add ChemFormula 
to other Shortcut menus that appear when the selection contains these special 
features.

Specific instructions for adding ChemFormula to right-click menus in some 
versions of Word follow.  For versions of Word that are not listed, please consult 
the Help system in Word for further guidance. 
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(This section assumes that you have already installed the 
ChemFormula macro into Word; Sect D.)

 
Adding ChemFormula to a Shortcut (right-click) menu; Word 6 or Word 7 (95)

The procedure for adding a macro to a shortcut (right-click) menu is the same as 
for adding it to the Tools menu, as described in Sect K, except:

“Change which menu”: Choose whichever menu you want to add ChemFormula 
to. It is most useful to add it to the menu listed as Text (Shortcut). Those who use 
fields or tables may also want to add ChemFormula to other Shortcut menus that 
appear when the selection contains these special features.

“Name on menu”: If you include an & before one letter of the name, that letter can 
be used to run ChemFormula, once the right-click menu has been displayed.

 
Adding ChemFormula to a Shortcut (right-click) menu; Word 97 or Word 2000

The instructions here are for the Text menu. For other menus, follow the same 
instructions, but substitute the appropriate name for Text.

1. Choose the Tools menu

In Word 2000: If the menu option “Customize” does not appear, double-click the word “Tools” 
on the menu bar.

2. Choose Customize

3. Choose the Toolbars tab

4. Scroll down to “Shortcut menus” (near the bottom of the list) and check its box

5. A new toolbar will appear, entitled “Shortcut Menus”. Choose “Text” from the 
menu.

6. Choose “Text” from the pull-out list

7. Choose the Commands tab in the Customize dialog box

8. Drag “Normal.NewMacros.ChemFormula” to an appropriate place on the “Text” 
menu

9. Right-click the new menu item, and change the name (in the name box) to 
Chem&Formula. 

10.Press Enter.

11. Close the Customize dialog box

12.Exit Word. If Word asks if you want to save changes to NORMAL, answer 
‘Yes’.
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M Re-installing ChemFormula

There are a couple of reasons why you might want to re-install ChemFormula. 

• You might want to update to a new version. 

• You might want to restore a previous version.

One way to re-install ChemFormula is to delete the current version (Sect N), and 
then repeat the original installation (Sect D). If you do this, you may also need to 
re-install any special features, such as menu assignments (Sect K or L).

Another way to re-install ChemFormula is to open the current macro text, and 
replace it with the new version. The procedure for doing this is very similar to the 
original installation procedure (Sect D).

Specific instructions for re-installation (by replacement) in some versions of Word 
follow.  For versions of Word not listed, it should be possible to re-install 
ChemFormula by following the installation instructions, but replacing the existing 
macro instead of creating a new macro.

 
Re-installation of ChemFormula in Word 6 or Word 7 (95)

1. Choose the Tools Menu

2. Choose Macro

3. Find the name, ChemFormula, and single click on it. The name will then 
appear in the Macro Name box.

4. Choose the Edit button, at the right. Word will now switch from the document 
window to a macro editing window. 

5. Remove all text, so that the macro editing window is empty.

6. Open the file MACRO6.DOC, which contains the text of ChemFormula for 
Word versions 6 and 7 (95). Select the entire file, “copy” it, and then paste it 
into the macro editing window.

7. Close the macro window: Choose the File menu, and choose Close. When 
Word asks if you want to save the macro, answer ‘Yes’.

8. Exit Word. If Word asks if you want to save changes to NORMAL.DOT, answer 
‘Yes’.

 
Re-installation of ChemFormula in Word 97 or Word 2000

1. Choose the Tools Menu

In Word 2000: If the menu option “Macro” does not appear, double-click the word “Tools” on 
the menu bar.
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2. Choose Macro, then choose Macros in the pull-out menu

3. Find the name, ChemFormula, and single click on it. The name will then 
appear in the Macro Name box.

4. Choose the Edit button, at the right. Word will now switch from the document 
window to a macro editing window. 

5. Remove all text, so that the macro editing window is empty.

6. Open the file MACRO97.DOC, which contains the text of ChemFormula for 
Word 97 or Word 2000. Select the entire file, “copy” it, and then paste it into 
the macro editing window.

7. Close the macro window: Choose the File menu, and choose “Close and 
return to Microsoft Word”. 

8. Exit Word. If Word asks if you want to save changes to NORMAL, answer 
‘Yes’.

 

N Deleting ChemFormula

Specific instructions for deleting ChemFormula in some versions of Word follow.  
For versions of Word not listed, it should be possible to delete ChemFormula from 
the Macros window (see Sect D).

 
Deleting ChemFormula in Word 6 or Word 7 (95)

1. Choose the Tools Menu

2. Choose Macro

3. Find the name, ChemFormula, and single click on it. The name will appear in 
the Macro Name box.

4. Choose the Delete button, at the right.

5. If asked whether you want to delete the specified macro, answer ‘Yes’.

6. Choose Close

7. Exit Word. If Word asks if you want to save changes to NORMAL.DOT, answer 
‘Yes’.

 
Deleting ChemFormula in Word 97 or Word 2000

1. Choose the Tools Menu



ChemFormula Manual. Page 18

In Word 2000: If the menu option “Macro” does not appear, double-click the word “Tools” on 
the menu bar.

2. Choose Macro, then choose Macros in the pull-out menu

3. Find the name, ChemFormula, and single click on it. The name will then 
appear in the Macro Name box.

4. Choose the Delete button, at the right.

5. If asked whether you want to delete the specified macro, answer ‘Yes’.

6. Choose Close.

7. Exit Word. If Word asks if you want to save changes to NORMAL, answer 
‘Yes’.

 

O History of ChemFormula versions

This section may guide users as to whether they should upgrade to a new version 
of ChemFormula.

Determining version date

The only definite way to determine the version date is to look at the code of the 
macro. The version date is on the first line of the macro. 

If you have the distributed files, you can just open the appropriate macroX.doc file 
in Word, and look at the top line. Alternatively, you can examine the macro you 
have installed. To do this, see the instructions in Sect M of the ChemFormula 
Manual for how to edit the macro.

The date listed in your file directory may not correspond to the actual version date, 
since the directory date can be updated from time to time as files are copied. 

 
Macro6; Macro97 (At this point the version histories are the same for both 
macros.)

July 2012.
• The manual was updated to show installation instructions for Word 2010.  

(Other sections have not yet been updated for this version of Word.)
• We thank Borislav Dopudja again for providing information on Word 2010.
• The manual is now being produced from a master copy stored in OpenOffice 

rather than Word.

November 2010. 
• The manual was updated to show installation instructions for Word 2003 and 

Word 2007. (Other sections have not yet been updated for these versions of 
Word.)

• We thank Borislav Dopudja for providing information on Word 2007.
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• This manual is now being provided as a pdf file (rather than as a doc file). 
• The web site address where ChemFormula is hosted has been updated. The 

web site was also updated in the macros themselves. 
• There are no changes in the running code of the macros; the file date shown 

within the macros was not changed. There is no need to change your version 
of the macro. 

• Those who are already using ChemFormula probably have no need to update 
anything, but the new manual will assist those installing it in Word 2003 and 
Word 2007.

June 2008. A minor problem in the Testfile was corrected. For "Chemicals with 
dots", some of the dots were shown already raised. ChemFormula would properly 
handle them, but the intent was that they start as regular periods; they are now 
regular periods, and ChemFormula should raise them. There are no changes in 
the macros, but those who use the Testfile might want to get this new zip file to get 
the corrected Testfile.

June 2006. This manual was updated, to reflect a change in how the 
ChemFormula files are packaged. This change has no effect for those who 
already have ChemFormula. Further, the contact information was updated, and 
that information was also updated in Section P, below. The running code remains 
the same, and the file date shown within the macros was not changed. There is no 
need to change your version of the macro. 

December 2003. Only the contact information was updated, and that information 
was also updated in Section P, below. The running code remains the same, and 
the file date shown within the macros was not changed. There is no need to 
change your version of the macro. 

September 21, 2000. “Non-breaking hyphens” are now treated the same as 
regular hyphens. (In previous versions, if you used a non-breaking hyphen in 
writing a negative charge, ChemFormula would not notice it. Use of a non-
breaking hyphen will prevent an unwanted line break at the - character.)

August 28, 2000. This version addresses two bugs that were reported.

1. The original version would not properly format the subscript 3 in 
(NH4+)3PO43-. More specifically, it would not allow a subscript after some 
charged groups in parentheses.

ChemFormula was designed to format molecular expressions that have no 
charge, and also to format ions that have a charge at the end of the expression. 
Including charges in the middle of an expression can confuse ChemFormula; it will 
format some such expressions but not others.

ChemFormula was designed to format molecular expressions that have no 
charge, and also to format ions. Including charges within a molecular formula can 
confuse ChemFormula.

This upgrade will format ions that are part of a chemical formula if the ion with its 
charge is in parentheses. If the ion is not in parentheses, the upgrade will format 
some cases and not others. See Sect G and the TestFile for examples.
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2. The original version was designed to allow formatting of the charge in e-, as 
would be written in redox equations. To do this, it checked for occurrences of “e-” 
and asked about the hyphen in all such cases (such as in “pre-installed”). In most 
cases, no error resulted from this; it was merely an unnecessary question. One 
type of such problem has now been eliminated. This upgrade will ignore hyphens 
in words that start with a lower case letter, such as “pre-installed”; it will still 
recognize the isolated “e-” (preceded by a space, a + or - sign, or a number) as 
“electron”. However, hyphens in words that begin with a capital letter will still 
confuse ChemFormula. Fixing this would require that ChemFormula stop and ask 
the user more questions; at this point, the problem does not seem sufficient to 
warrant this. This limitation of ChemFormula is listed above, in Sect G. We 
welcome feedback from users on this issue.

Sept 28, 1998. First official version. Earlier versions were distributed informally, for 
testing, but there are no formal records of what changes were made in specific 
versions prior to this date. If your version of ChemFormula is dated prior to this, 
you definitely should upgrade.

 

P Feedback

We welcome your comments, problems, questions, suggestions. It is particularly 
important that we hear about any problems if ChemFormula does not properly 
format chemical expressions.

Please e-mail

Greg Pearce <gjp23@cantab.net>

or

Bob Bruner <bbcmb@sigmaxi.net>

If you are reporting a problem or commenting on a specific feature, please specify 
the version of Word that you use. Please provide a sample of the text that is 
involved. 

If you are requesting files, please specify which version of Word you use.

Files sent by e-mail will be sent as a single ZIP file, containing the five files listed 
in Sect D.

ChemFormula is available at
http://www.gregpearce.co.uk/chemformula

 
CHEMFORM.ODT
12th July 2012

http://www.gregpearce.co.uk/chemformula

